Active Directory Replication Issues fixed

So, for the past few months I have been having major Active Directory Replication issues. Here are a few:-

1. trying to UNC to servers in other sites. I kept getting a login failure error. It worked with the IP Address. Very strange

2. When correcting to the primary site (Exchange host) users could not authenticate. They had to connect via OWA.

3. Trying to connect sharepoint from Doha. Users were redirected to the Dubai domain controller twice and then connection would fail.

I first thought this was an issue with the PDC. So i moved all the FSMO roles from my DC in Dubai to Doha. This didnt help.

Solutions

1. net stop KDC

2. netdom resetpwd /server:server_name /userd:domain_name\administrator /passwordd:administrator_password

3. net start KDC

Other commands used:

repadmin /syncall

readmin /showreps

http://sandeshdubey.wordpress.com/2011/10/02/secure-channel-between-the-dcs-broken/

Ref: http://www.windowstricks.in/2011/07/target-principal-name-is-incorrect.html

Advertisements

4 comments

  1. types of probiotic · September 28, 2014

    I must thank you for the efforts you’ve put in writing this site.
    I am hoping to check out the same high-grade content from you later on as well.
    In truth, your creative writing abilities has motivated
    me to get my own site now 😉

  2. Alex Robinson · November 2

    Hello. Does this fix the target principal name is incorrect errors when replicating?

    • adrianchatto · November 2

      Hi Alex,

      Sorry, its been some time. I really can’t remember. I wish you luck!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s